Python version supportΒΆ

The master branch and releases >= 0.7.0 onwards only support Python 3.7.0 or greater. The 0.6-maintenance branch and releases ~= 0.6.0 support Python 3.6.1 or greater.

Python 3.7.0 is required to utilise ContextVars and doing so considerably simplifies context management with tasks. Python 3.6.1 was required to utilise asynchronous generators.

The 0.6-maintenance branch will be supported for the near future with additional 0.6.X bugfixes.